![]() |
中国DOS联盟-- 联合DOS 推动DOS 发展DOS --联盟域名:www.cn-dos.net 论坛域名:www.cn-dos.net/forum |
| 游客 | 登录 | 注册 | 会员 | 搜索 | 中国DOS联盟 |
|
中国DOS联盟论坛 现在时间是 2026-09-23 11:53 |
共 47,812 主题排行 / 349,917 发帖 / 今日 0 篇 / 48,273 会员排行 |
| DOS批处理 & 脚本技术(批处理室) » win7中使用runas命令(替代右键“以管理员身份运行”) |
| 可打印版本 3,117 / 1 |
| 第1楼 zzkwhl | 发表于 2017-08-13 07:47 |
| 新手上路 发帖 1 积分 3 | |
|
win7中使用runas命令(替代右键“以管理员身份运行”) 在win7中,由于账户控制,使用cmd就不太方便,因为权限问题,比方说最简单的,输入“net start mssqlserver”(开启sql server服务),就会提示“拒绝访问”。最简单的解决办法就是右键选择“以管理员身份运行”,获取权限就够了。
现在发现这样也不方便,就想着是不是有什么命令可以达到这样的效果。查了下,就是“runas”。 在cmd里输入“runas /?”查看帮助,其实我要的只是以管理员账号运行就够了,输入“runas /user:administrator cmd”(用administrator运行cmd),之后会让输入密码,输入密码后报错了 “RUNAS 错误: 无法运行 - cmd 1058: 无法启动服务,原因可能是已被禁用或与其相关联的设备没有启动。” 这个是因为 “Secondary Logo”服务没有启动,这个服务是“在不同凭据下启用启动过程”。直接在cmd中输入services.msc,将服务从禁用改为手动就好了,之后再次输入runas命令,就会弹出新的cmd窗口,且是以administrator账号运行的,权限问题搞定。 |
|
| 第2楼 eech | 发表于 2017-08-17 00:22 |
| 高级用户 发帖 346 积分 906 | |
|
哎,这个论坛还有兄弟在坚持发贴啊,几年没来了
|
|
|
[ 联系联盟系统管理团队 -
中国DOS联盟 -
标准版 ] Sponsored by ifanr Inc | © 2001–2023 |